1. Home
  2. Docs
  3. geoSherpa Documentation
  4. Getting Started with geoSherpa

Getting Started with geoSherpa

geoSherpa is an interactive tutorial system, built for Web GIS that guides your users with step-by-step tours, video tutorials, and FAQs through your Web AppBuilder for ArcGIS and Geocortex applications. With geoSherpa, you can integrate your documentation into your Web GIS applications to simplify training, reduce support tickets, and increase Web GIS adoption.

geoSherpa delivers simplified, effective training supporting all your users and organizational workflows. It eliminates GIS jargon and reduces one-on-one training needs by offering engaging interactive, video, and text tutorials empowering all learning styles.

geoSherpa System Requirements

geoSherpa Planner

We recommend running geoSherpa Planner locally, not through an RDP connection. geoSherpa Planner is organization-licensed and there is no per user/install fee. geoSherpa Planner requires the following minimum system requirements:

  • OS: Microsoft Windows version 7 or later
  • Processor: 1.6 GHz or faster
  • RAM: 2 GB minimum, 4GB or greater recommended
  • Disk: 200MB minimum
  • Other: .NET Framework 4.5.2 or later

geoSherpa Widget for Web AppBuilder for ArcGIS

geoSherpa comes with a pre-built Widget for Web AppBuilder to make deployment and integration of geoSherpa into Web AppBuilder for ArcGIS as simple as possible. geoSherpa supports:

The ArcGIS Online version of Web AppBuilder for ArcGIS does not support custom widgets. This is unfortunately a limitation that is set by Esri. If you wish to use geoSherpa in all versions of Web AppBuilder, please upvote this ArcGIS Idea. Thank you!

geoSherpa Module for Geocortex Essentials

The geoSherpa Module and geoSherpa Deployment Tool for Geocortex are designed for the following version of Geocortex Essentials:

  • Geocortex Essentials, version 4.5 or later (earlier versions may work, but are untested)
  • Geocortex Viewer for HTML5, version 2.6 or later (earlier versions may work, but are untested)

Supported Web Browsers

geoSherpa is tested in modern web browsers. We tested geoSherpa in current versions of major desktop browsers including those made by Apple (Safari), Google (Chrome), Microsoft (Edge), Mozilla (Firefox), and Opera. We will also test in Microsoft’s chromium-based browser when it is released.

We do not support geoSherpa in Microsoft Internet Explorer. Microsoft, itself, no longer considers Internet Explorer a web browser but rather a “compatibility solution“. To keep our JavaScript code, as clean as possible, we chosen to not pollute our code with shims to support Internet Explorer. We apologize for any inconvenience.

Articles

Was this article helpful to you? Yes No
Close Menu